<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"
	prefix="og: https://ogp.me/ns#" > 
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="language" content="en, sv" />
<meta name="viewport" content="width=device-width" /> 	<link rel="Shortcut Icon" href="/wp-content/themes/snoflex/images/favicon.png" type="image/x-icon" />
<link rel="alternate" type="application/rss+xml" title="The A&#038;T Register RSS 2.0" href="https://ncatregister.com/feed/" />
<link rel="alternate" type="text/xml" title="The A&#038;T Register RSS .92" href="https://ncatregister.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="The A&#038;T Register Atom 0.3" href="https://ncatregister.com/feed/atom/" />


	<!-- Ads managed and served by AdPlugg - AdPlugg WordPress Ad Plugin v1.9.51 - https://www.adplugg.com -->
	<script data-cfasync="false">
		(function(ac) {
			var d = document, s = 'script', id = 'adplugg-adjs';
			var js, fjs = d.getElementsByTagName(s)[0];
			if (d.getElementById(id)) return;
			js = d.createElement(s); js.id = id; js.async = 1;
			js.src = '//www.adplugg.com/apusers/serve/' + ac + '/js/1.1/ad.js';
			fjs.parentNode.insertBefore(js, fjs);
		}('A48219467'));
	</script>
	<!-- / AdPlugg -->

			<title>Aggie Athletics Dominate Year Round | The A&amp;T Register</title>

		<!-- All in One SEO 4.1.0.2 -->
		<link rel="canonical" href="https://ncatregister.com/18710/the-score/aggie-athletics-dominate-year-round/" />
		<meta property="og:site_name" content="The A&amp;T Register | The Student News Site of North Carolina A&amp;T State University" />
		<meta property="og:type" content="article" />
		<meta property="og:title" content="Aggie Athletics Dominate Year Round | The A&amp;T Register" />
		<meta property="og:url" content="https://ncatregister.com/18710/the-score/aggie-athletics-dominate-year-round/" />
		<meta property="article:published_time" content="2021-04-28T16:00:04Z" />
		<meta property="article:modified_time" content="2021-04-28T15:41:53Z" />
		<meta name="twitter:card" content="summary" />
		<meta name="twitter:domain" content="ncatregister.com" />
		<meta name="twitter:title" content="Aggie Athletics Dominate Year Round | The A&amp;T Register" />
		<script type="application/ld+json" class="aioseo-schema">
			{"@context":"https:\/\/schema.org","@graph":[{"@type":"WebSite","@id":"https:\/\/ncatregister.com\/#website","url":"https:\/\/ncatregister.com\/","name":"The A&T Register","description":"The Student News Site of North Carolina A&T State University","publisher":{"@id":"https:\/\/ncatregister.com\/#organization"}},{"@type":"Organization","@id":"https:\/\/ncatregister.com\/#organization","name":"The A&T Register","url":"https:\/\/ncatregister.com\/"},{"@type":"BreadcrumbList","@id":"https:\/\/ncatregister.com\/18710\/the-score\/aggie-athletics-dominate-year-round\/#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/ncatregister.com\/#listItem","position":"1","item":{"@id":"https:\/\/ncatregister.com\/#item","name":"Home","description":"The Student News Site of North Carolina A&T State University","url":"https:\/\/ncatregister.com\/"},"nextItem":"https:\/\/ncatregister.com\/18710\/the-score\/#listItem"},{"@type":"ListItem","@id":"https:\/\/ncatregister.com\/18710\/the-score\/#listItem","position":"2","item":{"@id":"https:\/\/ncatregister.com\/18710\/the-score\/#item","name":"theSCORE","url":"https:\/\/ncatregister.com\/18710\/the-score\/"},"nextItem":"https:\/\/ncatregister.com\/18710\/the-score\/aggie-athletics-dominate-year-round\/#listItem","previousItem":"https:\/\/ncatregister.com\/#listItem"},{"@type":"ListItem","@id":"https:\/\/ncatregister.com\/18710\/the-score\/aggie-athletics-dominate-year-round\/#listItem","position":"3","item":{"@id":"https:\/\/ncatregister.com\/18710\/the-score\/aggie-athletics-dominate-year-round\/#item","name":"Aggie Athletics Dominate Year Round","url":"https:\/\/ncatregister.com\/18710\/the-score\/aggie-athletics-dominate-year-round\/"},"previousItem":"https:\/\/ncatregister.com\/18710\/the-score\/#listItem"}]},{"@type":"Person","@id":"https:\/\/ncatregister.com\/author\/ncatregister\/#author","url":"https:\/\/ncatregister.com\/author\/ncatregister\/","name":"Melvin Harris, theSCORE Lead Reporter","image":{"@type":"ImageObject","@id":"https:\/\/ncatregister.com\/18710\/the-score\/aggie-athletics-dominate-year-round\/#authorImage","url":"https:\/\/secure.gravatar.com\/avatar\/3cf5ed6e26237fd2bafe3b7efd242274?s=96&d=mm&r=g","width":"96","height":"96","caption":"Melvin Harris, theSCORE Lead Reporter"}},{"@type":"WebPage","@id":"https:\/\/ncatregister.com\/18710\/the-score\/aggie-athletics-dominate-year-round\/#webpage","url":"https:\/\/ncatregister.com\/18710\/the-score\/aggie-athletics-dominate-year-round\/","name":"Aggie Athletics Dominate Year Round | The A&T Register","inLanguage":"en-US","isPartOf":{"@id":"https:\/\/ncatregister.com\/#website"},"breadcrumb":{"@id":"https:\/\/ncatregister.com\/18710\/the-score\/aggie-athletics-dominate-year-round\/#breadcrumblist"},"author":"https:\/\/ncatregister.com\/18710\/the-score\/aggie-athletics-dominate-year-round\/#author","creator":"https:\/\/ncatregister.com\/18710\/the-score\/aggie-athletics-dominate-year-round\/#author","image":{"@type":"ImageObject","@id":"https:\/\/ncatregister.com\/#mainImage","url":"https:\/\/ncatregister.com\/wp-content\/uploads\/2018\/06\/NCAT_Aggie_Stadium_Scoreboard__Bryant_Center_From_Belk_Track.jpg","width":"2576","height":"1932"},"primaryImageOfPage":{"@id":"https:\/\/ncatregister.com\/18710\/the-score\/aggie-athletics-dominate-year-round\/#mainImage"},"datePublished":"2021-04-28T16:00:04-04:00","dateModified":"2021-04-28T15:41:53-04:00"},{"@type":"Article","@id":"https:\/\/ncatregister.com\/18710\/the-score\/aggie-athletics-dominate-year-round\/#article","name":"Aggie Athletics Dominate Year Round | The A&T Register","headline":"Aggie Athletics Dominate Year Round","author":{"@id":"https:\/\/ncatregister.com\/author\/ncatregister\/#author"},"publisher":{"@id":"https:\/\/ncatregister.com\/#organization"},"datePublished":"2021-04-28T16:00:04-04:00","dateModified":"2021-04-28T15:41:53-04:00","articleSection":"theSCORE, Aggies, MEAC, sports, Melvin Harris","mainEntityOfPage":{"@id":"https:\/\/ncatregister.com\/18710\/the-score\/aggie-athletics-dominate-year-round\/#webpage"},"isPartOf":{"@id":"https:\/\/ncatregister.com\/18710\/the-score\/aggie-athletics-dominate-year-round\/#webpage"},"image":{"@type":"ImageObject","@id":"https:\/\/ncatregister.com\/#articleImage","url":"https:\/\/ncatregister.com\/wp-content\/uploads\/2018\/06\/NCAT_Aggie_Stadium_Scoreboard__Bryant_Center_From_Belk_Track.jpg","width":"2576","height":"1932"}}]}
		</script>
		<!-- All in One SEO -->

<link rel="alternate" type="application/rss+xml" title="The A&amp;T Register &raquo; Aggie Athletics Dominate Year Round Comments Feed" href="https://ncatregister.com/18710/the-score/aggie-athletics-dominate-year-round/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v7.17.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-125318078-19"  type="text/javascript" data-cfasync="false"></script>
			<script type="text/javascript" data-cfasync="false">
				var mi_version = '7.17.0';
				var mi_track_user = true;
				var mi_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-125318078-19';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( mi_track_user ) {
					function __gtagTracker() {dataLayer.push( arguments );}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dZGIzZG' : true,
						                    });
					__gtagTracker( 'config', 'UA-125318078-19', {
						forceSSL:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var newtracker = function () {
								return new Tracker();
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = function (){
								var args = Array.prototype.slice.call(arguments);
								args.unshift( 'send' );
								__gaTracker.apply(null, args);
							};
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										var hitConverted, hitObject = false, action;
										if ( 'event' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[3] ) {
												hitObject = {
													'eventAction': arguments[3],
													'eventCategory': arguments[2],
													'eventLabel': arguments[4],
													'value': arguments[5] ? arguments[5] : 1,
												}
											}
										}
										if ( typeof arguments[2] === 'object' ) {
											hitObject = arguments[2];
										}
										if ( typeof arguments[5] === 'object' ) {
											Object.assign( hitObject, arguments[5] );
										}
										if ( 'undefined' !== typeof (
											arguments[1].hitType
										) ) {
											hitObject = arguments[1];
										}
										if ( hitObject ) {
											action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
											hitConverted = mapArgs( hitObject );
											__gtagTracker( 'event', action, hitConverted );
										}
									}
									return;
								}

								function mapArgs( args ) {
									var gaKey, hit = {};
									var gaMap = {
										'eventCategory': 'event_category',
										'eventAction': 'event_action',
										'eventLabel': 'event_label',
										'eventValue': 'event_value',
										'nonInteraction': 'non_interaction',
										'timingCategory': 'event_category',
										'timingVar': 'name',
										'timingValue': 'value',
										'timingLabel': 'event_label',
									};
									for ( gaKey in gaMap ) {
										if ( 'undefined' !== typeof args[gaKey] ) {
											hit[gaMap[gaKey]] = args[gaKey];
										}
									}
									return hit;
								}

								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = newtracker;
							__gaTracker.getByName = newtracker;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
							function __gtagTracker() {
								return null;
							}
							window['__gtagTracker'] = __gtagTracker;
							window['gtag'] = __gtagTracker;
					} )();
									}
			</script>
				<!-- / Google Analytics by MonsterInsights -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/ncatregister.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
			
	<link rel='stylesheet' id='dashicons-css'  href='https://ncatregister.com/wp-includes/css/dashicons.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://ncatregister.com/wp-includes/js/thickbox/thickbox.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https:////netdna.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.css?ver=4.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='elusive-css'  href='https://ncatregister.com/wp-content/plugins/menu-icons/vendor/kucrut/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://ncatregister.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-icons-css'  href='https://ncatregister.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/foundation-icons.min.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='https://ncatregister.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.12.5' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://ncatregister.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='flytedesk-digital-css'  href='https://ncatregister.com/wp-content/plugins/flytedesk-digital/public/css/flytedesk-digital-public.css?ver=20181101' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://ncatregister.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.6' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #d8e1eb;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Volkhov%3A400%2C700%7CRoboto+Slab%3A400%2C700%7CLato%3A400%2C700%7CKarla%3A400%2C700&#038;display=swap&#038;ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='flex-parallax-css'  href='https://ncatregister.com/wp-content/themes/snoflex/parallax/css/main.css?ver=20191203' type='text/css' media='all' />
<link rel='stylesheet' id='flex-flexslider-css'  href='https://ncatregister.com/wp-content/themes/snoflex/tools/flexslider/flexslider.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-superfish-css'  href='https://ncatregister.com/wp-content/themes/snoflex/tools/superfish/css/superfish.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-css'  href='https://ncatregister.com/wp-content/themes/snoflex/javascript/remodal.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-default-css'  href='https://ncatregister.com/wp-content/themes/snoflex/javascript/remodal-default-theme.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-stylesheet-css'  href='https://ncatregister.com/wp-content/themes/snoflex/style.css?ver=20210248' type='text/css' media='all' />
<link rel='stylesheet' id='newsletter-css'  href='https://ncatregister.com/wp-content/plugins/newsletter/style.css?ver=7.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-official-css'  href='https://use.fontawesome.com/releases/v5.15.2/css/all.css' type='text/css' media='all' integrity="sha384-vSIIfh2YWi9wW0r9iZe7RJPrKwp6bG+s9QZMoITbCckVJqGCCRhc+ccxNcdpHuYu" crossorigin="anonymous" />
<link rel='stylesheet' id='font-awesome-official-v4shim-css'  href='https://use.fontawesome.com/releases/v5.15.2/css/v4-shims.css' type='text/css' media='all' integrity="sha384-1CjXmylX8++C7CVZORGA9EwcbYDfZV2D4Kl1pTm3hp2I/usHDafIrgBJNuRTDQ4f" crossorigin="anonymous" />
<style id='font-awesome-official-v4shim-inline-css' type='text/css'>
@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.eot"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.svg#fontawesome") format("svg");
}

@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.eot"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.svg#fontawesome") format("svg");
}

@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.eot"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.svg#fontawesome") format("svg");
unicode-range: U+F004-F005,U+F007,U+F017,U+F022,U+F024,U+F02E,U+F03E,U+F044,U+F057-F059,U+F06E,U+F070,U+F075,U+F07B-F07C,U+F080,U+F086,U+F089,U+F094,U+F09D,U+F0A0,U+F0A4-F0A7,U+F0C5,U+F0C7-F0C8,U+F0E0,U+F0EB,U+F0F3,U+F0F8,U+F0FE,U+F111,U+F118-F11A,U+F11C,U+F133,U+F144,U+F146,U+F14A,U+F14D-F14E,U+F150-F152,U+F15B-F15C,U+F164-F165,U+F185-F186,U+F191-F192,U+F1AD,U+F1C1-F1C9,U+F1CD,U+F1D8,U+F1E3,U+F1EA,U+F1F6,U+F1F9,U+F20A,U+F247-F249,U+F24D,U+F254-F25B,U+F25D,U+F267,U+F271-F274,U+F279,U+F28B,U+F28D,U+F2B5-F2B6,U+F2B9,U+F2BB,U+F2BD,U+F2C1-F2C2,U+F2D0,U+F2D2,U+F2DC,U+F2ED,U+F328,U+F358-F35B,U+F3A5,U+F3D1,U+F410,U+F4AD;
}
</style>
<link rel='stylesheet' id='wp-paginate-css'  href='https://ncatregister.com/wp-content/plugins/wp-paginate/css/wp-paginate.css?ver=2.1.6' type='text/css' media='screen' />
<script type='text/javascript' src='https://ncatregister.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://ncatregister.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/ncatregister.com","hash_tracking":"false","ua":"UA-125318078-19"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ncatregister.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=7.17.0' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' id='flytedesk-digital-js-extra'>
/* <![CDATA[ */
var flytedesk_digital_publisher = {"uuid":"8b8312a5-430e-4eec-8889-2a510c8a8b87"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ncatregister.com/wp-content/plugins/flytedesk-digital/public/js/flytedesk-digital-public.js?ver=20181101' id='flytedesk-digital-js'></script>
<script type='text/javascript' src='https://ncatregister.com/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js?ver=5.7.1' id='flex-flexslider-script-js'></script>
<script type='text/javascript' src='https://ncatregister.com/wp-content/themes/snoflex/javascript/jquery-visible.js?ver=5.7.1' id='flex-jquery-visible-js'></script>
<script type='text/javascript' src='https://ncatregister.com/wp-content/themes/snoflex/tools/superfish/js/hoverintent.js?ver=20200802' id='flex-hoverintent-js'></script>
<script type='text/javascript' src='https://ncatregister.com/wp-content/themes/snoflex/tools/superfish/js/superfish.js?ver=20200803' id='flex-superfish-js'></script>
<script type='text/javascript' src='https://ncatregister.com/wp-content/themes/snoflex/tools/superfish/js/supersubs.js?ver=20200803' id='flex-supersubs-js'></script>
<script type='text/javascript' src='https://ncatregister.com/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js?ver=5.7.1' id='flex-scrollfix-js'></script>
<script type='text/javascript' src='https://ncatregister.com/wp-content/themes/snoflex/javascript/remodal.min.js?ver=5.7.1' id='flex-remodal-js'></script>
<script type='text/javascript' src='https://ncatregister.com/wp-content/themes/snoflex/javascript/jquery.cycle.all.min.js?ver=5.7.1' id='flex-cycle-js'></script>
<script type='text/javascript' src='https://ncatregister.com/wp-content/themes/snoflex/javascript/jcarousellite_1.0.1c4.js?ver=5.7.1' id='flex-bnticker-js'></script>
<script type='text/javascript' src='https://ncatregister.com/wp-content/themes/snoflex/javascript/menus-init.js?ver=20190826' id='flex-menus-js'></script>
<script type='text/javascript' id='flex-theme-js-js-extra'>
/* <![CDATA[ */
var frontend_ajax_object = {"ajaxurl":"https:\/\/ncatregister.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ncatregister.com/wp-content/themes/snoflex/javascript/sno-theme.js?ver=20210207' id='flex-theme-js-js'></script>
<script type='text/javascript' src='https://ncatregister.com/wp-content/themes/snoflex/parallax/js/skrollr.js?ver=5.7.1' id='flex-parallax-js'></script>
<link rel="https://api.w.org/" href="https://ncatregister.com/wp-json/" /><link rel="alternate" type="application/json" href="https://ncatregister.com/wp-json/wp/v2/posts/18710" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ncatregister.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ncatregister.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.1" />
<link rel='shortlink' href='https://ncatregister.com/?p=18710' />
<link rel="alternate" type="application/json+oembed" href="https://ncatregister.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fncatregister.com%2F18710%2Fthe-score%2Faggie-athletics-dominate-year-round%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://ncatregister.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fncatregister.com%2F18710%2Fthe-score%2Faggie-athletics-dominate-year-round%2F&#038;format=xml" />


<!-- Start of Open Graph Meta Tags -->

<meta property="og:title" content="Aggie Athletics Dominate Year Round" />
<meta property="og:type" content="article" />
<meta name="author" content="Melvin Harris" />
<meta property="og:url" content="https://ncatregister.com/18710/the-score/aggie-athletics-dominate-year-round/" />
<meta property="og:image" content="https://ncatregister.com/wp-content/uploads/2018/06/NCAT_Aggie_Stadium_Scoreboard__Bryant_Center_From_Belk_Track-1024x768.jpg" />
	<meta property="og:image:width" content="900" />
	<meta property="og:image:height" content="675" />
	<meta property="og:site_name" content="The A&T Register" />
	<meta property="og:description" content="Aggie Athletics has been on the ball this year, dominating the field in all sports. Whether it was on the court, pitch or the track, A&amp;T had great representation all across the board.  The Aggie Men’s Basketball team started off the success with winning the MEAC Southern Division Title. The Aggies ended a 30-year drought..." />
	<meta name="description" content="Aggie Athletics has been on the ball this year, dominating the field in all sports. Whether it was on the court, pitch or the track, A&amp;T had great representation all across the board.  The Aggie Men’s Basketball team started off the success with winning the MEAC Southern Division Title. The Aggies ended a 30-year drought..." />
	<meta property="article:section" content="theSCORE" />
	<meta property="article:tag" content="Aggies,MEAC,sports" />
<!-- End of Open Graph Meta Tags -->



<script>
	jQuery(document).ready(function() {
		var wpadminbar = jQuery('#wpadminbar').outerHeight();
		if (wpadminbar == null) { var wpadminbar = 0; }
		if (jQuery('#wpadminbar').is(":hidden")) { wpadminbar = 0; }

	
				jQuery('.subnavbarwrap').scrollToFixed({
			marginTop:  wpadminbar,
		});		
		
		
		
	
	});
</script>


<style type="text/css" media="screen">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</style>
</head>

<body data-rsssl=1 class="sno-animate-active">				<script type="text/javascript">
					jQuery(document).ready(function() {
						jQuery(".newsticker3-jcarousellite").jCarouselLite({
        					vertical: true,
        					visible: 1,
        					auto:5000,
        					speed:2000    					});
					});
				</script><div id="sno_mobile_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search-side"><div class="sno-side-menu side-close-icon"><i class="fas fa-times"></i><span class="icon-hidden-text">Close Menu</span></div><form method="get" class="searchform-alt-left" action="https://ncatregister.com/">
									<label for="s-alt-left" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-header-menu" class="menu"><li id="menu-item-81" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81"><a href="https://ncatregister.com/category/the-yard/">theYARD</a></li>
<li id="menu-item-17040" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17040"><a href="https://ncatregister.com/category/covid-19/">COVID-19</a></li>
<li id="menu-item-12140" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12140"><a href="https://ncatregister.com/category/theculture/">theCULTURE</a></li>
<li id="menu-item-80" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80"><a href="https://ncatregister.com/category/the-word/">theWORD</a></li>
<li id="menu-item-79" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-79"><a href="https://ncatregister.com/category/the-score/">theSCORE</a></li>
<li id="menu-item-78" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78"><a href="https://ncatregister.com/category/the-scene/">theSCENE</a></li>
<li id="menu-item-980" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-980"><a href="https://ncatregister.com/about/">About Us</a>
<ul class="sub-menu">
	<li id="menu-item-12538" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12538"><a href="https://ncatregister.com/meet-the-staff/">Meet the staff</a></li>
</ul>
</li>
<li id="menu-item-16515" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16515"><a href="https://ncatregister.com/ad-directory/">Ad Directory</a></li>
<li id="menu-item-13450" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13450"><a href="https://ncatregister.com/category/multimedia/">Multimedia</a></li>
</ul></div></ul></div><div id="wrap" class="bodywrap"><div id="mobile-menu"><div class="sitetitle"><div class="headerlink headersmall" style="display:none"><img src="https://ncatregister.com/wp-content/uploads/2019/01/SMALL-JPEG-HIRES.jpg" class="headerimage" alt="The Student News Site of North Carolina A&T State University" /></div><div class="headerlink headermedium" style="display:none"><img src="https://ncatregister.com/wp-content/uploads/2019/01/SMALL-JPEG-HIRES.jpg" class="headerimage" alt="The Student News Site of North Carolina A&T State University" /></div><div class="headerlink headerlarge"><img src="https://ncatregister.com/wp-content/uploads/2019/01/SMALL-JPEG-HIRES.jpg" class="headerlink headerimage" alt="The Student News Site of North Carolina A&T State University" /></div><h1 style="display:none" aria-hidden="true">The A&T Register</h1><script type="text/javascript">
						jQuery(document).ready(function(){
							jQuery(".headerlink").click(function(){
								window.location="https://ncatregister.com";

							});
						});
					</script><div id="hover-menu-side"><div class="sno-menu-side menu-icon"><i class="fas fa-bars"></i><span class="icon-hidden-text">Menu</span></div></div></div><div class="clear"></div></div><div class="topnavwrap">
	<div id="topnavbar">
			
			<div class="search-spacer"></div>

			<div class="topnavbarleft classic-icon">
				<style>.topnavbarleft { padding: 0px; width:auto; }</style>    	<a target="_blank" href="https://ncatregister.com/feed/rss/">
        	<div class="sno-icon social-border sno-rss">
	        	<i class="fa fa-rss"></i>
	        	<span class="icon-hidden-text">RSS Feed</span>
	        </div>
		</a>
        
        								   	    										
    
        				
   	    
    
    
        				
        				    					
        				
						
	    				
    
	
	    
	
	    	<a target="_blank" href="https://instagram.com/theatregister">
    		<div class="sno-icon social-border sno-instagram">
        		<i class="fa fa-instagram"></i>
        		<span class="icon-hidden-text">Instagram</span>
        	</div>
    	</a>
	    				
    		<a target="_blank" href="https://twitter.com/theatregister">
    		<div class="sno-icon social-border sno-twitter">
        		<i class="fa fa-twitter"></i>
        		<span class="icon-hidden-text">Twitter</span>
        	</div>
    	</a>
        				
	    	<a target="_blank" href="https://www.facebook.com/ncatregister/">
    		<div class="sno-icon social-border sno-facebook">
        		<i class="fa fa-facebook-f"></i>
        		<span class="icon-hidden-text">Facebook</span>
        	</div>
    	</a>
   
   <div class="social-spacer"></div>
   
   			</div>

			<div class="topnavbarcenter">
		        		            <script src="https://ncatregister.com/wp-content/themes/snoflex/javascript/date.js?ver=1" type="text/javascript"></script>
		        			</div>
	
			<div class="topnavbarright">
					<form method="get" id="searchform9627" action="https://ncatregister.com/">
			<div class="search-button-container" id="searchthis9627">
			<button type="submit" disabled="disabled" id="sno-search-navbar-9627" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s9627" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s9627" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit9627" style="display:none;" value="Search" />
		</form>
				</div>
			
	</div>
	<div class="clear"></div>
</div><div class="headerwrap"><div id="header" style="position:relative;"><div class="headerlarge"><a href="https://ncatregister.com"><img src="https://ncatregister.com/wp-content/uploads/2019/01/SMALL-JPEG-HIRES.jpg" class="headerimage" alt="The Student News Site of North Carolina A&T State University" /></a></div><h1 style="display:none">The A&T Register</h1></div></div><div class="bottom-menu"><div class='subnavbarwrap sno-sticky'
						data-align='center' 
						data-margin='2' 
						data-style='Bar' 
						data-minilogo='false' 
						data-mode='default' 
						data-height='30px' 
						data-width='970'><div class="subnavbarcontainer"><div id="subnavbar"><div id="subnavbarbackground"><div id="menu-b-menu"><nav aria-label="Main Menu"><div class="menu-header-menu-container"><ul id="menu-header-menu-1" class="sf-menu sno-bottom-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81"><a href="https://ncatregister.com/category/the-yard/">theYARD</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17040"><a href="https://ncatregister.com/category/covid-19/">COVID-19</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12140"><a href="https://ncatregister.com/category/theculture/">theCULTURE</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80"><a href="https://ncatregister.com/category/the-word/">theWORD</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-79"><a href="https://ncatregister.com/category/the-score/">theSCORE</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78"><a href="https://ncatregister.com/category/the-scene/">theSCENE</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-980" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://ncatregister.com/about/">About Us</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12538"><a href="https://ncatregister.com/meet-the-staff/">Meet the staff</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16515"><a href="https://ncatregister.com/ad-directory/">Ad Directory</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13450"><a href="https://ncatregister.com/category/multimedia/">Multimedia</a></li>
</ul></div></nav><div class="clear"></div></div><ul id='menu-more-bottom' class='sf-menu sf-js-enabled sf-shadow' style='display:none'><li id="menu-more-item-bottom" style="float:left;"><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"> »</span></a>
							<ul id="add-more-bottom" class="sub-menu"></ul>
							</li>
						</ul></div><div class="clear"></div></div></div></div></div><div class="clear"></div><div id="fullwrap" style="position:relative;"><div class="innerbackgroundwrap "><div class="innerbackground"><div id='snopostid-18710' class='snopostid'><div id='classic_story' class='sno-story-18710'><div id="content"><div id='contentleft'><div class="postarea"><ul class="snocategories"><li class='blockscategory'><a href='https://ncatregister.com/category/the-score/' rel='category tag'>theSCORE</a></li></ul><div role="main"><h1 class="storyheadline">Aggie Athletics Dominate Year Round</h1><div class="storyshadow"><div class="photowrap"><a class='modal-photo photooverlay' data-story-id='18710' data-photo-id='13763' href='#photo'><img src='https://ncatregister.com/wp-content/uploads/2018/06/NCAT_Aggie_Stadium_Scoreboard__Bryant_Center_From_Belk_Track-1024x768.jpg' alt='Aggie+Athletics+Dominate+Year+Round' style='width:100%' class='catboxphoto feature-image' /></a><div class='modal-photo photo-enlarge' data-story-id='18710' data-photo-id='13763'><i class='fas fa-search-plus'></i></div></div><div class="clear"></div><div class="photobottom"></div></div><div class="clear"></div><div class="permalinkphotobox"></div><div class="storydetails"><p><span class="storybyline"> <a href="https://ncatregister.com/staff_name/melvin-harris/" class="creditline">Melvin Harris</a>, theSCORE Lead Reporter</span><br /><span class="storydate"><span class="time-wrapper">April 28, 2021</span></span></p></div><div class="sharing sharing-top" data-story-id="18710"><a class='commentscroll' href='https://ncatregister.com/18710/the-score/aggie-athletics-dominate-year-round/#respond ' title='Jump to Comments'><div class='sharing-icon sno-comments  sharing-mobile-hide'><i class='fa fa-comments-o'></i><span class='icon-hidden-text'>Jump to Comments</span></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fncatregister.com%2F18710%2Fthe-score%2Faggie-athletics-dominate-year-round%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook sharing-mobile-hide"><i class="fa fa-facebook-f"></i><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=Aggie Athletics Dominate Year Round&amp;url=https%3A%2F%2Fncatregister.com%2F%3Fp%3D18710" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter sharing-mobile-hide"><i class="fa fa-twitter"></i><span class="icon-hidden-text">Share on Twitter</span></div></a><a href="#" onclick="return false;" class="modal-share share-email"><div class="sharing-icon sno-email sharing-mobile-hide"><i class="fa fa-envelope"></i><span class="icon-hidden-text">Share via Email</span></div></a><a rel="nofollow" href="//ncatregister.com/18710/the-score/aggie-athletics-dominate-year-round/?print=true"><div class="sharing-icon sno-print sharing-mobile-hide"><i class="fa fa-print"></i><span class="icon-hidden-text">Print</span></div></a></div><div class="sharing-clear"></div><span class="storycontent"><p><span style="font-weight: 400;">Aggie Athletics has been on the ball this year, dominating the field in all sports. Whether it was on the court, pitch or the track, A&amp;T had great representation all across the board. </span></p>
<p><span style="font-weight: 400;">The Aggie Men’s Basketball team started off the success with winning the MEAC Southern Division Title. The Aggies ended a 30-year drought and overcame serious doubt. Not only was the MEAC Title won, but senior Kameron Langley was named a BoxtoRow first-team All-American.</span></p>
<p><span style="font-weight: 400;">Coach Will Jones was selected as the Coaches Database and HoopsHD MEAC coach of the year and a Ben Jobe Award finalist. Unfortunately, due to a positive test before the MEAC tournament the team lost the chance to win the MEAC Championship. </span></p>
<p><span style="font-weight: 400;">The Lady Aggies Basketball team lived out the dream the men’s team so desperately wanted to do. The Ladies won in style too, winning the MEAC Championship on a game-winning three by senior Deja Winters. Beating Howard was no cake walk, however, when the lights shined brightest, Winters was ready to take that shot. </span></p>
<p><span style="font-weight: 400;">“</span><span style="font-weight: 400;">I was definitely confident in taking that shot. I feel like that’s a shot I would’ve taken during any other game really and they can probably agree to that,” </span><a href="https://ncatregister.com/18604/the-score/the-lady-aggies-reflect-on-this-past-season-and-ncaa-tournament/"><span style="font-weight: 400;">Winters said. </span></a></p>
<p><span style="font-weight: 400;">N.C. A&amp;T’s women’s bowling team made a lot of noise this year as well. The lady aggies won the MEAC this year and made big statements all season. Senior Cameron Strombeck noticed the team started to get more and more recognition as the season progressed. </span></p>
<p><span style="font-weight: 400;">“Every time we stepped into the building teams knew who we were.” </span><a href="https://ncatregister.com/18560/the-score/aggie-bowling-star-reflects-on-meac-title-victory/"><span style="font-weight: 400;">Strombeck said.</span></a></p>
<p><span style="font-weight: 400;"> </span><span style="font-weight: 400;">The bowling team finished as the sixth ranked team in the nation, this is the highest final ranking in school history. The Aggies took home their second MEAC title in four years. The sky&#8217;s the limit for this program, it is only up from here. </span></p>
<p><span style="font-weight: 400;">The N.C. A&amp;T Volleyball team made big strides this year and finally won their first MEAC title. The Aggies finished the season off on a 11-match winning streak and finished off the season with a big win against Coppin State to claim their title. </span></p>
<p><span style="font-weight: 400;">Senior Edie Brewer has been a big part of their success this season. Brewer is the back-to-back MEAC player of the year. Brewer averaged 6.62 assists, 1.89 kills per set and 2.47 digs per set. Brewer believed that the team’s resilience is why they were able to win as much as they did.</span></p>
<p><span style="font-weight: 400;">“</span><span style="font-weight: 400;">This team’s resilience is unmatched and we just continued to play for each other all season,” </span><a href="https://ncatregister.com/18631/the-score/ncat-volleyball-heads-to-nebraska-for-ncaa-tournament/"><span style="font-weight: 400;">Brewer said.</span></a></p>
<p><span style="font-weight: 400;">The N.C. A&amp;T track and field team has been breaking school and world records all season. The Aggies were ranked top ten in the nation after the Indoor Track and Field Championships and proved that they deserved this ranking. The men’s 4&#215;400 team broke the 4&#215;400 World Record with a time of 3:00.23. </span></p>
<p><span style="font-weight: 400;">The Lady aggies held their own as well, being ranked eighth in the nation. Sophomore Cambrea Sturgis leads Aggies in both the 100m and 200m races. Sturgis is ranked second in the nation with a 100m time of 11.21 seconds. The sophomore stud also ranks second in the 200m with a 22.87 finish. </span></p>
<p><span style="font-weight: 400;">Senior Trevor Stewart knows that people will always underrate the team because N.C. A&amp;T is a HBCU. However, Stewart and others use this as motivation to beat the odds. </span></p>
<p><span style="font-weight: 400;">“People are always going to discredit us no matter what we do. It boils down to we&#8217;re an HBCU. We&#8217;re not supposed to be doing this. It almost forces us to do it bigger and better. But we&#8217;re fine with that. It makes us better people, and it prepares us for life after college. Bigger and better is what the world is going to expect from us too,&#8221; </span><a href="https://www.becauseofthemwecan.com/blogs/culture/north-carolina-a-t-s-mens-track-team-makes-history-breaking-record-for-fastest-4x400-in-the-world"><span style="font-weight: 400;">Stewart said.</span></a></p>
<p><span style="font-weight: 400;">The Aggies put in a lot of work over the offseason and their play on the field is showing exactly that. </span></p>
<p><span style="font-weight: 400;">Winning is a part of the Aggie culture, this is what Aggies Do.</span></p>
<p>&nbsp;</p>
</span><div class="clear"></div></div><ul class="snotags"><li class="blockstag"><a href="https://ncatregister.com/tag/aggies/" rel="tag">Aggies</a></li><li class="blockstag"><a href="https://ncatregister.com/tag/meac/" rel="tag">MEAC</a></li><li class="blockstag"><a href="https://ncatregister.com/tag/sports/" rel="tag">sports</a></li></ul><div class="aboutwriter"><div class='aboutwritertitle'>About the Writer</div>
<!-- profile displayed from cache -->
<div class='storycreditboxwide'><a href="https://ncatregister.com/staff_profile/melvin-harris/"><div class='sc_title'>Melvin Harris, </div></a><div class='sc_bio' style='width:100%;'><p></p><div class='clear'></div></div></div><div class="clear"></div></div></div><div class="clear"></div><div id="commentswrap"><div class="widgetwrap"><div class="titlewrap cursorpoint" id="commentsbox"><div tabindex="0" role="button" aria-expanded="true" class="commenttoggle fa fa-minus-square"></div><div class="widgettitle-nonsno">Leave a Comment</div></div><div id='commentsbody' class='widgetbody' style='display:block;'>


<!-- You can start editing here. -->



<div id="commentblock">




	
		<!-- If comments are open, but there are no comments. -->



	 








<p id="respond">

If you want a picture to show with your comment, go get a <a href="https://en.gravatar.com">gravatar</a>.</p>





<form action="https://ncatregister.com/wp-comments-post.php" method="post" id="commentform">






<p><label for="name">Name (required)</label><br />

<input type="text" name="author" id="name" value="" size="50" tabindex="1" /></p>



<p><label for="email">Email Address (required)</label><br />

<input type="text" name="email" id="email" value="" size="50" tabindex="2" /></p>








<!--<p><small><strong>XHTML:</strong> You can use these tags: </small></p>-->


<div style="display:none"><label for="spam_stopper">Spam Control Field. Please Ignore</label><input type="text" name="sno_is_legit_comment" id="spam_stopper" value="SNO_Spam_Stopper"/></p></div>

	             		<script type="text/javascript">
							jQuery(function(){
								jQuery('input[name="sno_is_legit_comment"]').attr('name', 'sno_stop_spam');
							});
						</script>


<p><label for="words">Speak your mind</label><br /><textarea name="comment" id="words" cols="40" rows="10" tabindex="4"></textarea></p>



<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />

<input type="hidden" name="comment_post_ID" value="18710" /></p>






</form>









</div></div><div class="widgetfooter"></div></div></div></div><div id="sidebar" class="sidebar-template"><div style="clear:both"></div><section><div class="widgetwrap sno-animate"><div></div><div class="titlewrap" role="heading"><div class="widgettitle-nonsno">Polls</div></div><div class="widgetbody"><div id="polls-5" class="wp-polls">
		<p style="text-align: center;"><strong>Will you vote early this year?</strong></p><div id="polls-5-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
		<li>Yes <small>(97%, 37 Votes)</small><div class="pollbar" style="width: 97%;" title="Yes (97% | 37 Votes)"></div></li>
		<li>No <small>(3%, 1 Votes)</small><div class="pollbar" style="width: 3%;" title="No (3% | 1 Votes)"></div></li>
		</ul><p style="text-align: center;">Total Voters: <strong>38</strong></p></div>
		<input type="hidden" id="poll_5_nonce" name="wp-polls-nonce" value="aaaafbc805" />
</div>
<div id="polls-5-loading" class="wp-polls-loading"><img src="https://ncatregister.com/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
<ul><li><a href="/pollsarchive">Polls Archive</a></li></ul></div><div class="widgetfooter3"></div></div></section></div></div></div></div><div class="sno_teaserbar" id="sno_teaserbar"><div class="stb_nav"><div class="custom-navigation"><span class="flex-prev"><div class="stb_left"><div class="fa fa-angle-left"><div class="icon-hidden-text">Navigate Left</div></div></div></span></div></div><div id='stb-container' class='flexslider'><ul class="slides"><li class='stb-top-row'><div class='stb_image'><a href='https://ncatregister.com/18695/the-score/how-can-hbcus-land-a-top-basketball-recruit/#photo'><img src='https://ncatregister.com/wp-content/uploads/2021/04/IMG_5296-475x351.jpg' id='grow-stb18695'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='How can HBCUs land a top basketball recruit ?'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb18695').mouseenter(function() {
   											jQuery('#grow-stb18695').removeClass('shrink');
   											jQuery('#grow-stb18695').removeClass('grow');
   											jQuery('#grow-stb18695').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb18695').addClass('shrink');
   										});});</script><p class='stb-cat'>theSCORE</p><p class="relatedtitle"><a href="https://ncatregister.com/18695/the-score/how-can-hbcus-land-a-top-basketball-recruit/">How can HBCUs land a top basketball recruit ?</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://ncatregister.com/18684/the-score/aggie-bowling-qualifies-for-usbc-nationals/#photo'><img src='https://ncatregister.com/wp-content/uploads/2021/04/AJ6Q5588-475x340.jpg' id='grow-stb18684'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Aggie Bowling Qualifies for USBC Nationals'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb18684').mouseenter(function() {
   											jQuery('#grow-stb18684').removeClass('shrink');
   											jQuery('#grow-stb18684').removeClass('grow');
   											jQuery('#grow-stb18684').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb18684').addClass('shrink');
   										});});</script><p class='stb-cat'>theSCORE</p><p class="relatedtitle"><a href="https://ncatregister.com/18684/the-score/aggie-bowling-qualifies-for-usbc-nationals/">Aggie Bowling Qualifies for USBC Nationals</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://ncatregister.com/18646/the-score/former-titans-star-eddie-george-named-tennessee-state-coach/#photo'><img src='https://ncatregister.com/wp-content/uploads/2021/04/IMG_5262-475x317.jpg' id='grow-stb18646'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Former Titans Star Eddie George Named Tennessee State Coach'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb18646').mouseenter(function() {
   											jQuery('#grow-stb18646').removeClass('shrink');
   											jQuery('#grow-stb18646').removeClass('grow');
   											jQuery('#grow-stb18646').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb18646').addClass('shrink');
   										});});</script><p class='stb-cat'>theSCORE</p><p class="relatedtitle"><a href="https://ncatregister.com/18646/the-score/former-titans-star-eddie-george-named-tennessee-state-coach/">Former Titans Star Eddie George Named Tennessee State Coach</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://ncatregister.com/18631/the-score/ncat-volleyball-heads-to-nebraska-for-ncaa-tournament/#photo'><img src='https://ncatregister.com/wp-content/uploads/2019/10/moore-gym-475x315.jpg' id='grow-stb18631'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='NCAT Volleyball heads to Nebraska for NCAA Tournament'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb18631').mouseenter(function() {
   											jQuery('#grow-stb18631').removeClass('shrink');
   											jQuery('#grow-stb18631').removeClass('grow');
   											jQuery('#grow-stb18631').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb18631').addClass('shrink');
   										});});</script><p class='stb-cat'>theSCORE</p><p class="relatedtitle"><a href="https://ncatregister.com/18631/the-score/ncat-volleyball-heads-to-nebraska-for-ncaa-tournament/">NCAT Volleyball heads to Nebraska for NCAA Tournament</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://ncatregister.com/18618/the-score/tar-heels-hires-first-african-american-coach-in-school-history/#photo'><img src='https://ncatregister.com/wp-content/uploads/2021/04/IMG_5240-475x267.jpg' id='grow-stb18618'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='CHAPEL HILL, NC - APRIL 06: Hubert Davis speaks at a press conference introducing him as the new men's head basketball coach at the University of North Carolina at Dean E. Smith Center on April 6, 2021 in Chapel Hill, North Carolina. (Photo by Jeffrey Camarati/Getty Images)'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb18618').mouseenter(function() {
   											jQuery('#grow-stb18618').removeClass('shrink');
   											jQuery('#grow-stb18618').removeClass('grow');
   											jQuery('#grow-stb18618').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb18618').addClass('shrink');
   										});});</script><p class='stb-cat'>theSCORE</p><p class="relatedtitle"><a href="https://ncatregister.com/18618/the-score/tar-heels-hires-first-african-american-coach-in-school-history/">Tar Heels hires first African American coach in school history</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://ncatregister.com/18606/the-score/2021-march-madness-recap/#photo'><img src='https://ncatregister.com/wp-content/uploads/2021/04/Reviewed.com-RvEW-26945-march-madness-2-475x268.jpg' id='grow-stb18606'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='2021 March Madness Recap'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb18606').mouseenter(function() {
   											jQuery('#grow-stb18606').removeClass('shrink');
   											jQuery('#grow-stb18606').removeClass('grow');
   											jQuery('#grow-stb18606').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb18606').addClass('shrink');
   										});});</script><p class='stb-cat'>theSCORE</p><p class="relatedtitle"><a href="https://ncatregister.com/18606/the-score/2021-march-madness-recap/">2021 March Madness Recap</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://ncatregister.com/18604/the-score/the-lady-aggies-reflect-on-this-past-season-and-ncaa-tournament/#photo'><img src='https://ncatregister.com/wp-content/uploads/2020/10/NCAT-Basketball-475x317.jpg' id='grow-stb18604'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='The Lady Aggies reflect on this past season and NCAA tournament'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb18604').mouseenter(function() {
   											jQuery('#grow-stb18604').removeClass('shrink');
   											jQuery('#grow-stb18604').removeClass('grow');
   											jQuery('#grow-stb18604').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb18604').addClass('shrink');
   										});});</script><p class='stb-cat'>theSCORE</p><p class="relatedtitle"><a href="https://ncatregister.com/18604/the-score/the-lady-aggies-reflect-on-this-past-season-and-ncaa-tournament/">The Lady Aggies reflect on this past season and NCAA tournament</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://ncatregister.com/18587/the-score/2021-final-four-preview/#photo'><img src='https://ncatregister.com/wp-content/uploads/2021/04/1200px-2021_NCAA_Mens_Final_Four_logo.svg-475x475.png' id='grow-stb18587'  style='width:70px;min-width:70px;' class='catboxphoto' alt='2021 Final Four Preview'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb18587').mouseenter(function() {
   											jQuery('#grow-stb18587').removeClass('shrink');
   											jQuery('#grow-stb18587').removeClass('grow');
   											jQuery('#grow-stb18587').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb18587').addClass('shrink');
   										});});</script><p class='stb-cat'>theSCORE</p><p class="relatedtitle"><a href="https://ncatregister.com/18587/the-score/2021-final-four-preview/">2021 Final Four Preview</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://ncatregister.com/18578/the-score/n-c-mens-golf-finishes-second-at-invitational/#photo'><img src='https://ncatregister.com/wp-content/uploads/2021/03/FZVBVQZOCXCQOIY.20181031142543.jpg' id='grow-stb18578'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='N.C. A&T Men's Golf Finishes Second at Invitational'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb18578').mouseenter(function() {
   											jQuery('#grow-stb18578').removeClass('shrink');
   											jQuery('#grow-stb18578').removeClass('grow');
   											jQuery('#grow-stb18578').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb18578').addClass('shrink');
   										});});</script><p class='stb-cat'>theSCORE</p><p class="relatedtitle"><a href="https://ncatregister.com/18578/the-score/n-c-mens-golf-finishes-second-at-invitational/">N.C. A&#038;T Men&#8217;s Golf Finishes Second at Invitational</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://ncatregister.com/18560/the-score/aggie-bowling-star-reflects-on-meac-title-victory/#photo'><img src='https://ncatregister.com/wp-content/uploads/2020/10/IMG_3840-429x475.jpg' id='grow-stb18560'  style='width:70px;min-width:70px;' class='catboxphoto' alt='Aggie Bowling Star reflects on Meac Title Victory '/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb18560').mouseenter(function() {
   											jQuery('#grow-stb18560').removeClass('shrink');
   											jQuery('#grow-stb18560').removeClass('grow');
   											jQuery('#grow-stb18560').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb18560').addClass('shrink');
   										});});</script><p class='stb-cat'>theSCORE</p><p class="relatedtitle"><a href="https://ncatregister.com/18560/the-score/aggie-bowling-star-reflects-on-meac-title-victory/">Aggie Bowling Star reflects on Meac Title Victory </a></p></li></ul></div><div class="stb_nav"><div class="custom-navigation"><span class="flex-next"><div class="stb_right"><div class="fa fa-angle-right"><div class="icon-hidden-text">Navigate Right</div></div></div></span></div></div></div><div class="clear"></div><script type="text/javascript" charset="utf-8">
		jQuery(document).ready(function() {
			jQuery('#stb-container').flexslider({
				animation: "slide",
				animationLoop: true,
				customDirectionNav: jQuery(".stb_nav .custom-navigation span"), 
       			slideshow: false,
				itemMargin: 2,
				touch: true,
				itemWidth: 250,
				minItems: 1,
				move: 1,
				maxItems: 5
  			});

		});

			jQuery(document).ready(function(){
			
			var TB_CurrentScroll = 0; var TB_NextScroll = 0; var hbheight = 0;
			
			
			jQuery(window).scroll(function(event) {
				TB_CurrentScroll = TB_NextScroll;
				if (jQuery('#sno_hoverbar').is(":visible")) { hbheight = 50 }
				TB_NextScroll = jQuery(this).scrollTop();
				if (TB_NextScroll < TB_CurrentScroll && jQuery(document).scrollTop() > 500) {  // scrolling up on the page causes it to display
					if (jQuery('.sno_teaserbar').is(":hidden")) {
						jQuery('.sno_teaserbar').show();
						jQuery('.sno_teaserbar').stop().animate({ top: hbheight }, { duration: 300, queue: false });
					}
				}
				 else if ((TB_NextScroll > TB_CurrentScroll && jQuery(document).scrollTop() > 500) || jQuery(document).scrollTop() < 400 ){ // scrolling down on the page causes it to hide
					jQuery('.sno_teaserbar').stop().animate({
						top: '-86px'
						},200, function(){
							jQuery('.sno_teaserbar').hide();
						});
				} 
			});
				});
	</script></div></div></div><div style="clear:both;"></div><div class="footerwrap footer_single"><div id="footer"><div class="footername"><div class="footerleft"><p><a href="https://ncatregister.com">The A&#038;T Register</a></p></div><div class="footerright footer-icon"><style>.topnavbarleft { padding: 0px; width:auto; }</style>    	<a target="_blank" href="https://ncatregister.com/feed/rss/">
        	<div class="sno-icon social-border sno-rss">
	        	<i class="fa fa-rss"></i>
	        	<span class="icon-hidden-text">RSS Feed</span>
	        </div>
		</a>
        
        								   	    										
    
        				
   	    
    
    
        				
        				    					
        				
						
	    				
    
	
	    
	
	    	<a target="_blank" href="https://instagram.com/theatregister">
    		<div class="sno-icon social-border sno-instagram">
        		<i class="fa fa-instagram"></i>
        		<span class="icon-hidden-text">Instagram</span>
        	</div>
    	</a>
	    				
    		<a target="_blank" href="https://twitter.com/theatregister">
    		<div class="sno-icon social-border sno-twitter">
        		<i class="fa fa-twitter"></i>
        		<span class="icon-hidden-text">Twitter</span>
        	</div>
    	</a>
        				
	    	<a target="_blank" href="https://www.facebook.com/ncatregister/">
    		<div class="sno-icon social-border sno-facebook">
        		<i class="fa fa-facebook-f"></i>
        		<span class="icon-hidden-text">Facebook</span>
        	</div>
    	</a>
   
   <div class="social-spacer"></div>
   
   </div></div><div class="footertagline"><p>The Student News Site of North Carolina A&#038;T State University</p></div><div class="footersearch">	<form method="get" id="searchform921" action="https://ncatregister.com/">
			<div class="search-button-container" id="searchthis921">
			<button type="submit" disabled="disabled" id="sno-search-navbar-921" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s921" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s921" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit921" style="display:none;" value="Search" />
		</form>
	</div><div class="clear"></div><div class="footermenu"><div class="menu-social-container"><ul id="menu-social" class="footer-menu"><li id="menu-item-292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-292"><a href="https://twitter.com/TheATRegister">Twitter</a></li>
<li id="menu-item-293" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-293"><a href="https://instagram.com/theatregister/">Instagram</a></li>
<li id="menu-item-307" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-307"><a href="https://www.facebook.com/pages/The-AT-Register/98299217239">Facebook</a></li>
<li id="menu-item-308" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-308"><a href="https://www.youtube.com/user/ncatregister">YouTube</a></li>
</ul></div></div><div class="footercredit"><p>&copy; 2021  &bull; <a target='_blank' href='https://snoads.com/site/667'>Advertise</a> &bull;  <a href='https://snosites.com/why-sno/'>FLEX WordPress Theme</a> by <a href='http://snosites.com'>SNO</a> &bull; <a href="https://ncatregister.com/wp-login.php">Log in</a></p></div><div class="clear"></div></div></div>
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-125318078-19', 'auto');
			ga('require', 'displayfeatures');
			ga('send', 'pageview');
		</script> 	
		
	<div class='remodal-story-image' data-remodal-id='modal-photo' data-remodal-options='hashTracking: false, closeOnConfirm: false'><button data-remodal-action="close" class="remodal-close sno-overlay-close"><span class="icon-hidden-text">Close</span></button><div class="remodal-inner-container"></div></div><div class="remodal-share-story" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false"><button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button><div class="remodal-share-inner-container"></div></div><script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/ncatregister.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ncatregister.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105' id='thickbox-js'></script>
<script type='text/javascript' id='wp-polls-js-extra'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/ncatregister.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://ncatregister.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.6' id='wp-polls-js'></script>
<script type='text/javascript' src='https://ncatregister.com/wp-includes/js/wp-embed.min.js?ver=5.7.1' id='wp-embed-js'></script>
</div><div id="sno_hoversearch"><div class="sno-search-close"style="float:right;"><i class="fas fa-times"></i></div><div class="hover-search-area"><form method="get" id="searchform-alt" action="https://ncatregister.com/">
											<label for="s-alt" class="assistive-text">Search</label>
											<input type="text" class="field" name="s" id="s-alt" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
											<input type="submit" class="submit" name="submit" id="searchsubmit-alt" value="Search" />
											<button type="submit" id="sno-hover-search-button" class="sno-submit-search sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
										</form></div></div><div id="sno_hoverbar"><div class="hoverheader"><div id="search-top"><div class="sno-search-button"><i class="fa fa-search"></i><span class="icon-hidden-text">Activate Search</span></div></div><div class="socialmedia"><div class="sharing sharing-top" data-story-id="18710"><a class='commentscroll' href='https://ncatregister.com/18710/the-score/aggie-athletics-dominate-year-round/#respond ' title='Jump to Comments'><div class='sharing-icon sno-comments  sharing-mobile-hide'><i class='fa fa-comments-o'></i><span class='icon-hidden-text'>Jump to Comments</span></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fncatregister.com%2F18710%2Fthe-score%2Faggie-athletics-dominate-year-round%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook sharing-mobile-hide"><i class="fa fa-facebook-f"></i><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=Aggie Athletics Dominate Year Round&amp;url=https%3A%2F%2Fncatregister.com%2F%3Fp%3D18710" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter sharing-mobile-hide"><i class="fa fa-twitter"></i><span class="icon-hidden-text">Share on Twitter</span></div></a><a href="#" onclick="return false;" class="modal-share share-email"><div class="sharing-icon sno-email sharing-mobile-hide"><i class="fa fa-envelope"></i><span class="icon-hidden-text">Share via Email</span></div></a><a rel="nofollow" href="//ncatregister.com/18710/the-score/aggie-athletics-dominate-year-round/?print=true"><div class="sharing-icon sno-print sharing-mobile-hide"><i class="fa fa-print"></i><span class="icon-hidden-text">Print</span></div></a></div><div class="sharing-clear"></div></div><div id="back-top"><a id="snotop" href="#top" title="Return to Top"><div class="sno-arrow-up"><i class="fa fa-arrow-up"></i><span class="icon-hidden-text">Scroll to Top</span></div></a></div><div class="lf_headerleft"><a href="/"><img src="https://ncatregister.com/wp-content/uploads/2019/01/SMALL-JPEG-HIRES.jpg" alt="The Student News Site of North Carolina A&T State University" /></a></div><div class="hover_title"><div class="hover_titletext">Aggie Athletics Dominate Year Round</div><span id="progress-bar"><span id="progress-bar-color"></span></span></div></div><div class="clear"></div></div><div id="hoverbar_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search"><form method="get" class="searchform-alt-left" action="https://ncatregister.com/">
									<label for="s-alt-left-hoverbar" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left-hoverbar" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-header-menu-2" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-81"><a href="https://ncatregister.com/category/the-yard/">theYARD</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17040"><a href="https://ncatregister.com/category/covid-19/">COVID-19</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12140"><a href="https://ncatregister.com/category/theculture/">theCULTURE</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80"><a href="https://ncatregister.com/category/the-word/">theWORD</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-79"><a href="https://ncatregister.com/category/the-score/">theSCORE</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78"><a href="https://ncatregister.com/category/the-scene/">theSCENE</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-980"><a href="https://ncatregister.com/about/">About Us</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12538"><a href="https://ncatregister.com/meet-the-staff/">Meet the staff</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16515"><a href="https://ncatregister.com/ad-directory/">Ad Directory</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13450"><a href="https://ncatregister.com/category/multimedia/">Multimedia</a></li>
</ul></div></ul></div><script type="text/javascript">
			jQuery(document).ready(function(){
				
	
				function sharingIconsResize() {
					if (jQuery(window).width() < 850) {
						var socialwidth;
						var count = jQuery("#mobile-socialmedia .sharing-mobile-show").length;
						if (count != 0) {
							socialwidth = 100 / count;
							jQuery('#mobile-socialmedia .sharing-icon').width(socialwidth + '%');
						}
					} else {
						jQuery('#sno_hoverbar .sharing-icon').width('50px');
					}
				}
								
				jQuery('.sno-search-button').click(function() {
					jQuery('#sno_hoversearch').fadeToggle();
					jQuery('#sno_hoversearch').css({ top: '0' });
					jQuery('#s-alt').focus();
				});
				jQuery('.sno-search-close').click(function() {
					jQuery('#sno_hoversearch').fadeToggle();
					jQuery('#sno_hoversearch').css({ top: '-50px' });
				});
	
				var NavScrollTop		= jQuery(window).scrollTop();
	    		
	    		if( jQuery('.navbarwrap').length ) {
	    			var	TopNavOffset 		= jQuery('.navbarwrap').offset().top;
					var TopNavDistance		= (TopNavOffset - NavScrollTop);
	   	 		}
	   	 		if( jQuery('.subnavbarwrap').length ) {
		   	 		var	BottomNavOffset 	= jQuery('.subnavbarwrap').offset().top;
		   	 		var	BottomNavDistance	= (BottomNavOffset - NavScrollTop);
	   	 		}
	   	 		
	   	 		jQuery('#hoverbar_menu .mobile-menu').height( jQuery(window).height() - 50);
	   	 		
	   	 		var HoverOffset = 0, HoverOffset2 = 0;
					   	 		var HoverHeight = jQuery('#sno_hoverbar').outerHeight();
	   	 		var HoverHeight2 = jQuery('#sno_hoverbar').outerHeight();
	   	 		
					
				var CurrentScroll = 0;
				var WindowHeight = jQuery(document).height() - jQuery('.footerwrap').height();
				
									WindowHeight -= jQuery('#commentswrap').height();		
								
				
/*
				jQuery('.sno-menu').click(function() {
				
					jQuery('#hoverbar_menu').fadeToggle();
					jQuery('.menu-icon').toggle();
					jQuery('.close-icon').toggle();
					jQuery('#hoverbar_menu').css({ height: jQuery(window).height() - 50 });
				
				});
*/
				
				jQuery(window).scroll(function(event) {
					var NextScroll = jQuery(this).scrollTop();
	
					var ScrollPercent = (NextScroll / (WindowHeight - jQuery(window).height())) * 100;
					
	
					jQuery('#progress-bar-color').css({ width: ScrollPercent + '%'});
					jQuery('#hoverbar_menu').css({ top: jQuery('#sno_hoverbar').height() });
					
/*
					if ( ScrollPercent > 100 ) {
												jQuery('.sno-arrow-up').css({ background: '#3881da', color: '#eee'});
						jQuery('.sno-menu').css({ background: '#3881da', color: '#eee'});
						jQuery('.socialmedia .sharing-icon').css({ opacity: 1 })
						
							
					} else {
												jQuery('.sno-arrow-up').css({ background: '#eee', color: '#ccc'});
						jQuery('.sno-menu').css({ background: '#eee', color: '#ccc'});
					}
*/
					var headerLocation = jQuery("#wrap").offset().top;
					if (NextScroll > CurrentScroll && jQuery(document).scrollTop() > headerLocation) {
						if (jQuery('#sno_hoverbar').is(":hidden")) {
							jQuery('#sno_hoverbar').show();
							jQuery('#sno_hoverbar').stop().animate({ top: '0' }, { duration: 300, queue: false });
								
															if( jQuery('.subnavbarwrap').length ) {	
									jQuery('.subnavbarwrap').stop().animate({ top: HoverHeight2 +'px'}, { duration: 300, queue: false });
								}
														
															var lpb = jQuery('.lf_headerleft').width();
																var rpb = 50 + jQuery('.socialmedia').width();
																	rpb += jQuery('#sno_hoverbar .sno-search-button').width();
																jQuery('#progress-bar').css({ left: lpb + 'px', right: rpb + 'px'})
								        			}
	
	
	        			
					} else if (NextScroll < CurrentScroll && jQuery(document).scrollTop() < ( headerLocation + 300 ) && jQuery('#sno_hoverbar').is(":visible")) {
						
							jQuery('#hoverbar_menu').hide();
							jQuery('.close-icon').hide();
							jQuery('.menu-icon').show();
							jQuery('#hoverbar_menu').hide();
							jQuery('#sno_hoverbar').stop().animate({
								top: '-50px'
								},300, function(){
									jQuery('#sno_hoverbar').hide();
								});
							if ( jQuery('.navbarwrap').length ) { jQuery('.navbarwrap').stop().animate({ top: HoverOffset + 'px'},300); }
							if ( jQuery('.subnavbarwrap').length ) { jQuery('.subnavbarwrap').stop().animate({ top: HoverOffset2 + 'px'},300); }
	
					}
				CurrentScroll = NextScroll;
				});
	
	
			});
	
		</script></body></html>